●ファイル属性詳細設定/取得

※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

情報

作者名:クジラ飛行丸(?)
引用元:ひまわり命令一覧「ファイル属性取得」
勝手に改変

概要

簡単にファイル属性を設定したり取得したりします。

解説

ファイル属性詳細設定

引数

F:ファイル
S:属性リスト(配列)

返り値

1or0(成功or失敗)

ファイル属性詳細取得

引数

F:ファイル

返り値

属性リスト(配列)


サンプルプログラム

テストファイル=「{デスクトップ}testですよ.txt」。
テストファイルに「てすてす」を保存。

//属性設定
「読み込み専用属性
隠しファイル属性」にテストファイルをファイル属性詳細設定。

//属性取得
A=テストファイルのファイル属性詳細取得して言う。

//確認してみよう
もし、(Aの0から「ディレクトリ属性」を配列検索)≧0ならば、「これはディレクトリ属性です。」と言う。
違えば、「ディレクトリ属性じゃありません。」と言う。

//削除しとく
テストファイルをファイル削除。

//本体

●ファイル属性詳細設定({=?}FをSに|Sへ)
  もし、Fの存在=いいえならば、「0」で戻る。
  ZOKUとは数値=0。
  もし、(Sの0から「ノーマル属性」を配列検索)≧0ならば、ZOKU=ZOKU+ノーマル属性。
  もし、(Sの0から「アーカイブ属性」を配列検索)≧0ならば、ZOKU=ZOKU+アーカイブ属性。
  もし、(Sの0から「ディレクトリ属性」を配列検索)≧0ならば、ZOKU=ZOKU+ディレクトリ属性。
  もし、(Sの0から「システムファイル属性」を配列検索)≧0ならば、ZOKU=ZOKU+システムファイル属性。
  もし、(Sの0から「隠しファイル属性」を配列検索)≧0ならば、ZOKU=ZOKU+隠しファイル属性。
  もし、(Sの0から「読み込み専用属性」を配列検索)≧0ならば、ZOKU=ZOKU+読み込み専用属性。
  もし、ZOKU=0ならば、「0」で戻る。
  FをZOKUにファイル属性設定。
  「1」で戻る。

●ファイル属性詳細取得({=?}Fの|Fから|Fで|Fを)
  LISTとは配列=空。A=Fのファイル属性取得。
  もし、A=「-0000001」ならば、LIST=「存在なし」。LISTで戻る。
  もし、AND(A,ノーマル属性)=ノーマル属性ならば、「ノーマル属性」をLISTに配列追加。
  もし、AND(A,アーカイブ属性)=アーカイブ属性ならば、「アーカイブ属性」をLISTに配列追加。
  もし、AND(A,ディレクトリ属性)=ディレクトリ属性ならば、「ディレクトリ属性」をLISTに配列追加。
  もし、AND(A,システムファイル属性)=システムファイル属性ならば、「システムファイル属性」をLISTに配列追加。
  もし、AND(A,隠しファイル属性)=隠しファイル属性ならば、「隠しファイル属性」をLISTに配列追加。
  もし、AND(A,読み込み専用属性)=読み込み専用属性ならば、「読み込み専用属性」をLISTに配列追加。
  LISTで戻る。


名前:
コメント:


ツールボックス

下から選んでください:

新しいページを作成する
ヘルプ / FAQ もご覧ください。