●冒頭一致

※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

情報

作者名:五十六
引用元:なし

概要

文字列の冒頭が一致しているかどうか返します。
冒頭一致というか、片方がもう片方を(冒頭に)内包しているかどうかで判別します。

解説

引数

A:文字列
B:文字列

返り値

1or0(成功or失敗)

サンプルプログラム

もし、「https//」と「http://」が冒頭一致ならば
  「一致しています」と言う。
違えば
  「一致していません」と言う。

もし、「https//」と「http」が冒頭一致ならば
  「一致しています」と言う。
違えば
  「一致していません」と言う。

//本体

●冒頭一致(AとBが|AとBで)
  AAとは数値。BBとは数値。AAAとは文字列。BBBとは文字列。
  AA=Aのバイト数。BB=Bのバイト数。
  もし、AA=BBならば
    もし、A=Bならば、1で戻る。
    違えば、0で戻る。
  もし、AA>BBならば
    AAA=Aの1から(BB)バイト抜き出す。
    もし、AAA=Bならば、1で戻る。
    違えば、0で戻る。
  もし、AA<BBならば
    BBB=Bの1から(AA)バイト抜き出す。
    もし、BBB=Aならば、1で戻る。
    違えば、0で戻る。


名前:
コメント:


ツールボックス

下から選んでください:

新しいページを作成する
ヘルプ / FAQ もご覧ください。