●実行ファイル作成

※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

情報

作者名:ゆちボン/とくめい/五十六
引用元:なでしこプログラム掲示板「実行ファイル化の自動化」

概要

ソースコードから実行ファイルを作成します。(vnako/gnako/cnako)

解説

引数

ソース:プログラムのソースコード

実行ライブラリ:vnako.nakoとかへの絶対パス
 なでしこ有環境の場合:省略可
 なでしこ無環境の場合:省略した場合、vnako.exeとかと同じフォルダにvnako.nakoを入れとけばおーけー

実行ファイル:vnako.exeとかへの絶対パス
 なでしこ有環境の場合:「vnako」とか「vnako.exe」とかでおーけー
 なでしこ無環境の場合:省略不可

保存先:作成したプログラムの保存先

※なるべくなでしこ無環境として考えてください。(インストール場所が違うだけでうまく動かなくなるので)

サンプルプログラム

『「テストですよー」と言う。』を「vnako」で「{デスクトップ}testes.exe」に実行ファイル作成。

//各種プラグインは手動で追加
ナデシコフォルダ=「{PROGRAMFILESパス}nadesiko_lang\」。
DNAKOファイル=「{ナデシコフォルダ}plug-ins\dnako.dll」。
DNAKOファイルから「{デスクトップ}plug-ins\dnako.dll」へファイルコピー。

「{デスクトップ}testes.exe」を起動。

//本体

●実行ファイル作成(ソースを{=?}実行ライブラリと実行ファイルで保存先に)
  ナデシコフォルダ=「{PROGRAMFILESパス}nadesiko_lang\」。
  ソースファイルパス=母艦パスで「ソースファイル.nako」のユニークファイル名生成。
  ソースをソースファイルパスに保存。
  パックファイルパス=母艦パスで「パックファイル.nako」のユニークファイル名生成。
  実行方式=(実行ファイルからファイル名抽出)の「.exe」を空に置換。
  実行方式で条件分岐
    「vnako」ならば
      もし、(実行ファイル=「vnako」)または(実行ファイル=「vnako.exe」)ならば
        実行ファイル=「{ナデシコフォルダ}vnako.exe」。
        実行ライブラリ=「{ナデシコフォルダ}lib\vnako.nako」。
      違えば
        もし、実行ライブラリ≠空ならば、抜ける。
        実行ライブラリ=「{ナデシコフォルダ}vnako.nako」。
    「gnako」ならば
      もし、(実行ファイル=「gnako」)または(実行ファイル=「gnako.exe」)ならば
        実行ファイル=「{ナデシコフォルダ}gnako.exe」。
        もし、実行ライブラリ≠空ならば、抜ける。
        実行ライブラリ=「{ナデシコフォルダ}lib\gnako.nako」。
      違えば
        もし、実行ライブラリ≠空ならば、抜ける。
        実行ライブラリ=「{ナデシコフォルダ}gnako.nako」。
    「cnako」ならば
      もし、(実行ファイル=「cnako」)または(実行ファイル=「cnako.exe」)ならば
        実行ファイル=「{ナデシコフォルダ}cnako.exe」。
        もし、実行ライブラリ≠空ならば、抜ける。
        実行ライブラリ=「{ナデシコフォルダ}lib\cnako.nako」。
      違えば
        もし、実行ライブラリ≠空ならば、抜ける。
        実行ライブラリ=「{ナデシコフォルダ}cnako.nako」。
    違えば
      「実行方式が不明です」という。戻る。
  もし、実行ライブラリの存在=いいえならば、「実行ライブラリがありません」と言う。戻る。
  もし、実行ファイルの存在=いいえならば、「実行ファイルがありません」と言う。戻る。
  「{実行ライブラリ}={実行方式}.nako=1{改行}{ソースファイルパス}=nadesiko.nako=1」をパックファイルパスにパックファイル作成。
  実行ファイルとパックファイルパスを保存先にパックファイル結合。
  もし、「{保存先からパス抽出}plug-ins\」のフォルダ存在=いいえならば、
    「{保存先からパス抽出}plug-ins\」にフォルダ作成。
  ソースファイルパスをファイル削除。パックファイルパスをファイル削除。


名前:
コメント:


ツールボックス

下から選んでください:

新しいページを作成する
ヘルプ / FAQ もご覧ください。